cool IT Team-Blog

Kompatibilitätsprobleme mit SharePoint 2013 und Internet Explorer 11

Wenn man SharePoint 2013 gemeinsam mit Internet Explorer 11 benützt, kann es immer wieder mal vorkommen, dass ein Feature nicht angeboten wird, obwohl es eigentlich funktionieren müsste. Dieser Blog-Beitrag soll helfen, ein wenig Licht ins Dunkel zu bringen und eine Lösung für die meisten Probleme anzubieten.

Folgende Funktionen im SharePoint 2013 treiben im IE11 mit uns ihren Schabernack:
  • Open with Explorer
  • Visio Web Access Webpart
  • Edit Webpart
  • Einige Funktionen, die in der Rubrik Edit page verfügbar sein sollten, wie zum Beispiel Insert
  • Webpart
Beispiel: Geladener Visio Workflow im Visio Web Access Webpart - die Anzeige ist einfach leer:

ein Visio Diagramm in IE11

Vielleicht kennen Sie das eine oder andere Problem und haben schon festgestellt, dass ein Umschalten des User Agent Strings Abhilfe verschaffen kann:
  1. Drücken Sie die Taste F12. Die Developer Toolbar wird eingeblendet.
  2. Wechseln Sie in der linken schwarzen Leiste auf den untersten Eintrag (Emulation)
  3. Wählen Sie hier Internet Explorer 9 oder 10 aus:
Setzen des User Agent Strings

Das Problem mit dieser Lösung ist nur, dass dies keine dauerhafte Einstellung ist und sich auch auf andere Seiten auswirkt. Ein Versetzen in den Compatibility Mode hilft nicht.

So, wo kommt das Problem nun her?

Die Rahmenbedingungen sind:
  • Sie bedienen die SharePoint Site über das Internet
  • Sie verwenden HTTPS
Das Problem ist ein Sicherheitsproblem, denn einige Scripts, die normalerweise reibungslos laufen, fallen in dieser Konstellation den Sicherheitseinstellungen zum Opfer und werden nicht korrekt geladen (so oder so ähnlich).

Abhilfe verschafft langfristig, indem man die Website der Website Zone lokales Intranet hinzufügt. Wenn diese Lösung machbar ist und keine anderen Umstände dagegen sprechen, kann man sich so helfen, ohne andere Funktionen bei der Verwendung des Internets zu beeinträchtigen.
  1. Klicken Sie auf das Rädchen, um zum Administrationsmenü zu gelangen
    InternetEinstellungen.JPG
  2. Wählen Sie Interneteinstellungen
  3. Klicken Sie auf die Registerkarte Sicherheit (hier englisch)
    Sicherheitseinstellungen
  4. Wählen Sie lokales Intranet als Zone aus und klicken Sie auf Sites
  5. Klicken Sie auf Erweitert
    Lokales Intranet
  6. Fügen Sie die aktuelle Adresse hinzu. Es empfiehlt sich, hier als Subdomain * zu wählen, da der SharePoint typischerweise unterschiedliche Subdomains verwendet. Zum Beispiel wird die MySite oft auf eine eigene Subdomain gelegt.
    AddDomain.JPG

Nun funktioniert wieder alles wie von Zauberhand, da hier andere Sicherheitseinstellungen greifen.

Ist doch cool, oder?

LG,
Sabine.
Verfasst: 02.07.2014 21:36:10 von Sabine Stiller
Tags: Internet Explorer 11, Intranet, SharePoint, SharePoint 2013, Visio, Visio Web Access Webpart

1


Kommentare
Für diesen Blogbeitrag liegen zurzeit keine Kommentare vor.
Einen Kommentar schreiben



 Security code